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Modify a document template

Existing templates are available in the administrator area.

They are in ODT format and can be edited with LibreOffice or OpenOffice (except for 
QR code templates).

This document does not explain how to paginate a document, but rather how to make 
certain parts of a document variable so that LabBook can complete them.
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Defining a variable

You need to insert a "placeholder." Insert => Fields 
=> Other fields

The syntax in the "Substitute" field is as follows:
o.category_name.data_name.

(see list of data available at the end of the document).

You can then change the font style to suit your preferences.
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Define a logical test

IF test

Via a substitute: Insert => Fields => Other fields.
In the example, the complete substitute is: if test="o.report.full_comm == 'Y' and 
o.rec.comm".

All tests must be closed with their equivalent using the following syntax.
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CHOOSE test

Via a hyperlink: Insert => Hyperlink.

The principle is to choose between two or more options.

Here, we want to use bold when bold_value equals Y and normal font when it does not 
equal Y.

Define a hyperlink opening CHOOSE followed by one (or more) hyperlinks WHEN then
/WHEN, then OTHERWISE and /OTHERWISE, and finally conclude with /CHOOSE.

Hyperlinks must follow the following syntax in the URL field: relatorio://...
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Note: The Text section can be filled in as you wish, only the URL section must follow 
the required syntax.

FOR loop

Via a hyperlink: Insert => Hyperlink.
To repeat a paragraph or line with a set of data (such as o.l_data and o.l_data.l_res).
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Open the FOR with a hyperlink

Close the FOR with a hyperlink
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Define a frame for an image

Insert => Frame

The syntax to use in the Options tab, then in the name fields, is as 
follows: image: o.category.data_name
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To replicate an image several times on the same template, you must adapt the simple syntax 
mentioned above, ensuring that the ending number is unique in your template for each image.
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Define a QR code template

QRC templates are used to generate an image in the form of a QR code.
This image can be inserted into a result template (see: Defining a frame for an image).
Only one QR code can be inserted into a result template.
This generation is triggered by setting an analysis variable in the repository (Example 
analysis B4274).

The QR code template is in TOML format

Default example provided:
# -*- coding:utf-8 -*-
version = 1

[QRcode]
# Integer from 1 to 40 that controls the size of the QR Code (the smallest, 
version 1, is a 21x21 matrix)
# Set to 0 and use the fit parameter when making the code to determine this 
automatically.

version = 0

# Options: L, M, Q, H (respectively 7%, 15%, 25%, 30% or less errors can be 
corrected)

error_correction = "H"

# Dynamic value options:
# {{ o.rec.rec_date }}, {{ o.rec.num_y }}, {{ o.rec.num_m }}, {{ o.rec.num_d }}
# {{ o.pat.lastname }}, {{ o.pat.firstname }}, {{ pat.maidenname }}, {{ 
o.pat.middlename }},
# {{ o.pat.code_lab }}, {{ o.pat.code }}, {{ o.pat.sex }}, {{ o.pat.age }}, {{ 
o.pat.age_unit }}
# {{ o.res.value }}, {{ o.res.unit }}, {{ o.res.valid_date }}

text = "{{ o.pat.lastname }} {{ o.pat.firstname }} , {{ o.pat.code_lab }} , {{
o.pat.sex }} , {{ o.pat.age }} {{ o.pat.age_unit }} , {{ o.res.valid_date }} ,
{{ o.res.value }}"
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Available data

For the analysis report template
Logo section
o.logo This is an image

Translated words or expressions section
o.label.phone Tel
o.label.fax Fax
o.label.email Email
o.label.record File
o.label.code Code
o.label.born Born on
o.label.admit Admitted on
o.label.at in
o.label.bed Bed
o.label.by by
o.label.exam_presc Examination prescribed on
o.label.save Saved on
o.label.edit Edited on
o.label.analyzes ANALYSIS
o.label.results RESULT
o.label.references References
o.label.previous Previous
o.label.comm Comment
o.label.validate Validated by
o.label.technician technician
o.label.sampling_info Sampling information
o.label.sampled_at Samples the
o.label.received_at Received

Laboratory information section
o.lab.name 
o.lab.head2 
o.lab.head3 
o.lab.addr 
o.lab.phone 
o.lab.phone 
o.lab.fax 
o.lab.email
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Report information section
o.report.title Report 
o.report.status
o.report.full_comm Y or N
o.report.full_head Y or N 
o.report.date_now
o.report.time_now 
o.report.replace 
o.report.replace_date
o.report.report_pwd Y or N

File information section
o.rec.rec_date 
o.rec.num_y 
o.rec.num_m 
o.rec.num_d 
o.rec.num_int
o.rec.hosp Y or N
o.rec.hosp_date 
o.rec.hosp_service 
o.rec.hosp_bed 
o.rec.presc_date 
o.rec.presc_name
o.rec.custody Y or N
o.rec.comm_title Clinical information 
o.rec.comm
o.rec.date_vld 
o.rec.num 
o.rec.rec_hosp_num 
o.rec.date_save

Patient information section
o.pat.anonymous 
o.pat.code 
o.pat.code_lab 
o.pat.lastname 
o.pat.firstname 
o.pat.maidenname 
o.pat.middlename 
o.pat.birth 
o.pat.age 
o.pat.age_unit 
o.pat.age_days
o.pat.sex Unknown, Male, or Female
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o.pat.addr 
o.pat.zipcode 
o.pat.city 
o.pat.district 
o.pat.pbox 
o.pat.phone 
o.pat.phone2 
o.pat.profession 
o.pat.nationality
o.pat.resident Y or N
o.pat.blood_group 
o.pat.blood_rhesus 
o.pat.id_of_your_new_field

This type of keyword must be enclosed in an existence test (see example below):

Section containing information about the analyses in this file
o.l_data🡪 this is a list, so you need to loop through it with a for 

o.l_data.fam_name
o.l_data.ana_name
o.l_data.ana_comm🡪 this is a list, so you need to loop through it with a for 
o.l_data.validate

o.l_data.l_res🡪 this is a list, so you need to loop through it with a for o.l_data.l_res.label

o.l_data.l_res.value 
o.l_data.l_res.unit 
o.l_data.l_res.references 
o.l_data.l_res.prev_date 
o.l_data.l_res.prev_val 
o.l_data.l_res.prev_unit
o.l_data.l_res.bold_value Y or N
o.l_data.l_res.highlight Y or N
o.l_data.l_res.formatting Y or N 
o.l_data.l_res.comm
o.l_data.l_res.var_comm 
o.l_data.l_res.valueConv 
o.l_data.l_res.unitConv
o.l_data.ana_outsourced Outsourced
o.l_data.ana_ast Y or N
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o.l_data.ana_with_one_result Y or N 
o.l_data.tech_validate
o.l_data.l_res.value_ast R, I, or S
o.l_data.l_res.in_report Y or N

Section containing information about the samples in this file
o.samples🡪 This is a list, so you need to loop through it with a for 

loop. o.samples.date
o.samples.type 
o.samples.qty 
o.samples.stat 
o.samples.sampler 
o.samples.date_receipt 
o.samples.time_receipt 
o.samples.comm 
o.samples.location 
o.samples.location_det 
o.samples.storage 
o.samples.code 
o.samples.code_ana

QR code information section
o.res.value 
o.res.unit 
o.res.valid_date
o.res.qrcode it is an image

Signature section

o.signature This is an image
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For the transfer form template
Logo section
o.logo it is an image

Translated words or expressions section
o.label.phone 
o.label.fax 
o.label.email 
o.label.record 
o.label.code 
o.label.born 
o.label.admit 
o.label.at 
o.label.bed 
o.label.by 
o.label.exam_presc 
o.label.save 
o.label.edit 
o.label.analyzes 
o.label.results 
o.label.references 
o.label.previous 
o.label.comm 
o.label.validate

Laboratory information section
o.lab.name 
o.lab.head2 
o.lab.head3 
o.lab.addr 
o.lab.phone 
o.lab.phone 
o.lab.fax 
o.lab.email

Report information section
o.report.title Transfer form
o.report.full_comm Y or N
o.report.full_head Y or N 
o.report.date_now
o.report.time_now
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File information section
o.rec.rec_date 
o.rec.num_y 
o.rec.num_m 
o.rec.num_d 
o.rec.num_int
o.rec.hosp Y or N
o.rec.hosp_date 
o.rec.hosp_service 
o.rec.hosp_bed 
o.rec.presc_date 
o.rec.presc_name
o.rec.custody Y or N
o.rec.comm_title Clinical information 
o.rec.comm
o.rec.date_vld 
o.rec.num 
o.rec.rec_hosp_num 
o.rec.date_save

Patient information section

o.pat.anonymous 
o.pat.code 
o.pat.code_lab 
o.pat.lastname 
o.pat.firstname 
o.pat.maidenname 
o.pat.middlename 
o.pat.birth 
o.pat.age 
o.pat.age_unit 
o.pat.age_days
o.pat.sex Unknown, Male, or Female 
o.pat.addr
o.pat.zipcode 
o.pat.city 
o.pat.district 
o.pat.pbox 
o.pat.phone 
o.pat.phone2 
o.pat.profession 
o.pat.nationality
o.pat.resident Y or N
o.pat.blood_group 
o.pat.blood_rhesus 
o.pat.id_of_your_new_field
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This type of keyword must be enclosed in an existence test (see example below):

Section containing information about the analyses in this file
o.l_data🡪 this is a list, so it must be looped with a for 

o.l_data.fam_name
o.l_data.ana_name
o.l_data.ana_comm🡪 this is a list, so you need to loop through it with a for 
o.l_data.ana_outsourced Y or N
o.l_data.ana_ast Y or N

Section containing information about the samples in this file
o.samples🡪 This is a list, so you need to loop through it with a for loop.

o.samples.date 
o.samples.type 
o.samples.qty 
o.samples.stat 
o.samples.sampler 
o.samples.date_receipt 
o.samples.time_receipt 
o.samples.comm 
o.samples.location 
o.samples.location_det 
o.samples.storage 
o.samples.code 
o.samples.code_ana
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For the administrative file label template
Available labels section
o.img.code39 this is an image
o.img.qrcode it is an image

File information section
o.rec.num 
o.rec.num_y 
o.rec.num_m 
o.rec.num_d 
o.rec.rec_date

Patient information section
o.pat.anonymous Y or N 
o.pat.code
o.pat.code_lab 
o.pat.lastname 
o.pat.firstname 
o.pat.maidenname 
o.pat.middlename 
o.pat.birth 
o.pat.age 
o.pat.age_unit 
o.pat.age_days
o.pat.sex Unknown, Male, or Female 
o.pat.addr
o.pat.zipcode 
o.pat.city 
o.pat.district 
o.pat.pbox 
o.pat.phone 
o.pat.phone2 
o.pat.profession 
o.pat.nationality
o.pat.resident Y or N
o.pat.blood_group 
o.pat.blood_rhesus 
o.pat.id_of_your_new_field

This type of keyword must be enclosed in an existence test (see example below):
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For the billing template

Translated words or expressions section

o.label.total Total
o.label.total_remain Total to pay
o.label.analyzes_requested Requested analyses
o.label.discount Discount on billing
o.label.percent_discount Discount percentage 
o.label.percent_insurance Health insurance/mutual insurance 
percentage

Billing section
o.invoice.title Invoice
o.invoice.date_now 
o.invoice.time_now

File information section
o.rec.invoice_num 
o.rec.type_discount 
o.rec.percent_discount 
o.rec.percent_insurance 
o.rec.invoice_total 
o.rec.invoice_remain

Section containing information about the analyses in this file

o.l_data.ana_name 
o.l_data.ana_code 
o.l_data.ana_loinc
o.l_data.ana_outsourced Outsourced 
o.l_data.ana_price
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For the billing statement template

Section on translated words or expressions

o.label.total Total
o.label.total_remain Total to pay
o.label.billing_status Billing status
o.label.from_ from
o.label.to_ to
o.label.rec_num File No.
o.label.receipt_num Receipt number
o.label.bill_num Invoice number
o.label.price Price
o.label.remain Amount due

Billing status section
o.bill.title Billing status 
o.bill.date_now
o.bill.time_now 
o.bill.date_beg 
o.bill.date_end 
o.bill.bill_total 
o.bill.bill_remain

Section containing information about the analyses in this file

o.l_data.rec_num 
o.l_data.receipt_num 
o.l_data.bill_num 
o.l_data.bill_price 
o.l_data.bill_remain



Manual Modifying a document template version 3.6 22

For the activity report template

Translated words or expressions section

o.label.by_type Analyses by type of request
o.label.by_age Analysis by age group
o.label.external External
o.label.inpatient Hospitalized
o.label.oncall On call
o.label.legend M = Male, F = Female, U = Unknown 
o.label.activity_report Activity report 
o.label.analysis_family Analysis family

o.label.age_col1 
o.label.age_col2 
o.label.age_col3 
o.label.age_col4
(one line o.label.age_colX per interval defined in age_interval_setting)

o.label.M H
o.label.F F
o.label.U I

Activity report section
o.activity.title Activity report 
o.activity.date_now
o.activity.time_now 
o.activity.family 
o.activity.date_beg 
o.activity.date_end

Type and age section

o.l_type.ana_name 
o.l_type.ana_code 
o.l_type.ext_M 
o.l_type.ext_F 
o.l_type.ext_U 
o.l_type.inp_M 
o.l_type.inp_F 
o.l_type.inp_U 
o.l_type.onc_M 
o.l_type.onc_F 
o.l_type.onc_U 
o.l_type.tot_M



Manual Modifying a document template version 3.6 23

o.l_type.tot_F 
o.l_type.tot_U 
o.l_age.ana_name 
o.l_age.ana_code 
o.l_age.age_tot_M 
o.l_age.age_tot_F 
o.l_age.age_tot_U

o.l_age.age_col1_M 
o.l_age.age_col1_F 
o.l_age.age_col1_U 
o.l_age.age_col2_M 
o.l_age.age_col2_F 
o.l_age.age_col2_U 
o.l_age.age_col3_M 
o.l_age.age_col3_F 
o.l_age.age_col3_U 
o.l_age.age_col4_M 
o.l_age.age_col4_F 
o.l_age.age_col4_U
(a series of three lines o.l_age.age_colX_M / _F / _U for each age interval)


